[Solved] Choice of font family not working

Hi

I just noticed today that on the Thunkable Live app, my choice of font family is not reflected when I view the app on my phone in the Live app or when I compile a downloadable version. It is showing the default font no matter what I enter as the ‘font family’ in advanced tab. The font does however reflect on the ‘Design’ page of my project.

Any idea how to fix this?

Thanks.

1 Like

Are you using the Drag & Drop or Snap to Place interface?

Can you share a link to a project that demonstrates this issue?

I was able to change the font family in the Drag & Drop interface and see the changes in Thunkable Live on my iPhone.

1 Like

Hi Tatiang - this is in the original snap to place interface. Can I share a private link to you as it’s a private project?

Just want to draw your attention to an important issue here. Thunkable will use the default font when the selected font is not available and if you look closely in the list of font families between iOS and Android you will notice that there is no common fonts and therefore when you select a font family then make sure to test with the correct environment (iOS or Android).

Thanks @muneer. I use two text labels - when the screen starts, the app checks the OS and hides one and uses the other. I had used Courier for iOS and Monotype for Android. This has been working fine for months without problem but for some reason, this isn’t working today.

1 Like

Update - every month or so as I have worked on the app I have saved a duplicate of the project. I have checked the previous versions of the app and they all have the same problem in that I cannot change any of text in labels to a different font.

I am confused!

1 Like

Can you create a new project and only have two Labels one with default font and one with your chosen font and share it here for others to test? This will help you to see if it is a common issue or something related to a specific situation.

Hi @muneer

Project link is here: Thunkable

Also attached are screen grab of the designer view on my laptop and how the picture looks on my Thunkable live app.

I have used Apple font families and iOS.

Thanks.


1 Like

That project looks correct, with the selected fonts rendered, in both the browser preview and in Thunkable Live on my iPhone 11. Maybe it’s a device-related issue? You should probably contact Support for help with this. Also consider filing a bug report:

I have tested on my side and see it working on both iPhone and Android. Of course I changed the Font Family name for the Android and I can see the effect changing in the phone display.

Thanks both - I’ll reach out to support.

2 Likes

Thanks for the report @slothball

I see it not working in the most up to date version of the companion app too. Thank you for sending the project. I am writing up a bug report now and will touch base when I know more.

This could have something to do with an upcoming feature related to fonts:eyes:

1 Like

Hey @slothball, can you check to make sure you are on the most up to date version of the companion app and try again?

I believe there was some work done today by @tingc and she rocked out a fix! Please do check on your device and check back in when you get a chance! :blush:

@jared and @tingc - all fonts across my projects are now working again. Thanks for working your magic!

2 Likes

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.