[Solved]Can not read & write realtime db Firebase error = "o.default.get(this.settings).database is not a function..."

Hello This is a first time here for me :slight_smile:

Hi, I have a strange problem with my app.
I have create ease app to connect with firebase and Iot (esp8266) , It 's go well and nice untill last 4 days this app can not connect to firebase anymore , My Iot device still connect to firebase but Thunkable X app can not work both read & write data.I try for many time such as

  • increase sign up and sign in (authentification work),

  • change rule ,

  • create new project in both app and firebase and change API key & URL

but all of this not work , I use Iphone x(10) for live test and try to download real app inside but still failed.I saw error

'o.default.get(this.settings).database is not a function. (In ‘o.default.get.(this.settings).database()’, ‘o.default.get(this.settings).database’ is undefined)

sorry if my english not well.I m from Thailand.Thank you

1 Like

hi @teerapat.dj, this is a known issue. is this still a problem or has the issue resolved for you already?


Solved !
Thanks Jared , after I post this in 1 hour. Suddenly it work again, I do not know why. I want to say thank you to someone who solved this for me ^_^.

1 Like