Problems with the "Create sprite_type" block

Hello!
Today all projects that use the “Create sprite_type” command have stopped working correctly.
Project link: https://x.thunkable.com/copy/b476160f2c0ca3d19cdce6aad65567e8
In this project, sprites must be created and moved down. But now one sprite is created and remains in one place.

And we noticed a peculiarity: if you copy this project into your account and immediately run the test, everything works. But if you go to “Blocks” and then run the test, the “Create sprite_type” block stops working correctly.

1 Like

Hello @maggik555bydwc
Thanks for sharing this issue. We’ll flag it to our engineering team and provide an update as soon as possible.

I also have the same problem,
I tried to “Create sprite_type” [ST_bullet] at a [Rocket]'s position and “set the sprite y’s speed to 100” whenever another sprite [shoot_btn] were clicked – The result is the sprite was created, but can’t move at y coordinate at all. Here are the ss of my code:

Screenshot 2024-01-30 at 4.23.58 AM
thunkable-bug

This is what also makes it peculiar :

When I previewed the following project, it seems to have “create sprite_type” command working perfectly: Thunkable – Space Invaders Project. But when I remixed it, and previewed it from my account, the “create sprite_type” command seems to be broken – with the same behaviour as I shown above.

So from this case I believe there is a bug related to “create sprite_type” command

Please fix this @ioannis

Hello @playdemo.bc
Our engineering team was able to identify the root cause and is working on a fix.

2 Likes

same issue with my projects, please notify when solved

encountered same issue, the component block seem to be invalid. Waiting for update.

Hello @maggik555bydwc @playdemo.bc @dylanha01081 @leecitra
Thank you again for your patience. I would like to let you know that we have now officially released a fix for this bug.

Please keep in mind that you may need to do a hard refresh of your browser for the changes to take effect in your project. If this issue is present on the Thunkable Live app, you will want to update that through the App Store and/or Google Play Store before any changes will occur. If your downloaded or published app is affected by this bug, you will need to re-download or re-publish your app for these changes to take effect.

​Please let us know if you have any issues

2 Likes