Problems downloading and opening .apk files


I don’t think I’m doing anything wrong as I’ve downloaded a couple of apps before but I seem to be having issues with this one.

When I go to download the app to Android I get a message up saying the servers are busy, wait 5 minutes or become a pro member.

Then, once it downloads I’m not getting an APK I’m getting a notepad. I thought, okay I’ll email that to myself and see if it works, but if doesn’t. The email sends but there’s no attachment included in the email.

Thanks for any help in advance.

I finished coding my app last night and although I need to finish off making the design I thought I would download the app so that I could play around with it today and make sure there were no obvious bugs.

The problem I’m having is that it’s downloading into notepad and the apk doesn’t download.

I’ve downloaded a few apps on thunkable before and never had this issue before.

What am I doing wrong?

Thanks for any help in advance.

Do you want to say that when you click on the Download Android App command, Notepad opens?

When I click download android it downloads to my laptop but opens up as notepad after its downloaded.

Are you using a Windows laptop @beadle07, yeah?

I am.

Did you change the default program by any chance?

If you got to your Downloads folder, is the file type still .apk?

Is there an option to right click and choose “Open with…”?

What do you usually open your apks with, or do you transfer them to a phone from there?

I normally just download the file then email it to myself and open it on my phone.

I’ll have to check the file type later as I’m no where near my laptop at the moment.

I’ll post again later when I’m home.

Thanks for the help so far.

1 Like

Just had a quick look. When I click download android app it shows in the bottom left as an apk file but when I click it to download it downloads a notepad.

When I try and open it another way it only gives me two options:

  1. Open as notepad or
  2. Open with Internet explorer.

I’ve tried to open with Internet explorer but nothing happens.

Any idea what the apk normally opens with so I can download it or get it from the Microsoft store?


Are you fundamentally using Internet Explorer, which is one of the most unsuccessful browsers?

This sounds like the download has successfully completed. It should be in your downloads folder - have you checked there?

Unless you have an emulator installed on your computer, you won’t be able to open an Android application on a Windows computer. It sounds to me like the .apk downloads, then when you click on it you are trying to open it and Windows is trying to use Notepad to open your .apk file.

I’d recommend that instead of clicking on anything you open your email and attach the .apk file that should be in your Downloads folder.

Hope that helps @beadle07

Aha - I knew there was a reason why I stopped doing this.

If you’re a Gmail user, Google actually won’t let you attach .apk files in case they contain malicious code.

What I used to do was move the .apk into a Google Drive folder and the you can share a link via email, or you can use the Google Drive app to open it on your phone.

To be honest, what I’ve found to be quickest now is just to log into Thunkable X on my phone, open the project I want, click download and then the .apk downloads directly to my device. Once it’s downloaded make sure you close the tab with Thunkable open on your phone.

Hope that helps.

This is what I ended up doing last night and it worked a treat.

The problem I have is that I plan on emailing it to a couple of friends to test it for me once I have improved upon the design so they suggest where I can improve on the project.

Its a strange one because I’ve used this laptop on a couple of practice projects and never had any issue either downloading or emailing.

I use my outlook email and not my Gmail email as well so don’t think it’s that.

I’m currently restoring my laptop back to the date I last downloaded a project successfully. I’ll update once its done and let you know if it works.

No I use chrome.

I’m currently restoring my laptop back to the last project date that I successfully downloaded a project from.

If that doesn’t work I think I need to download a program that will open . Apk files.

The system restore didn’t work in respect to it going back to default and opening my .apk downloads, however, it does now tell me that it doesn’t have anything to open them with, rather than it opening them in notebook.

So, I need to know what to download to open .apk for windows - if anyone knows that would be a great help.

To open the apk, use the Android emulator - Bluestacks 4

1 Like