Problems after download Apk file from Thunkable X

Until a while ago I had no problem to download Android APKs, but since the download method has changed (via email and no longer directly from the website)my APK is downloaded correctly but when I go to install it does not load correctly the app missing icons in each screen.
The problem occurs only with Android, while with Apple the download of the app is correct.

Hi @Francesco_Veratti
What do yo mean by importing an aia file from Classic?

With regards to the missing images, can you point us to your project? if it is public, can you send a copy link. If not, please DM the details. Thanks!

1 Like

Hello Jose thank you for your reply!

This the link of my project Thunkable

I download apk for Android via email from thunkable X but when I install the app some icons and images are missing

Hi @Francesco_Veratti thanks, we’ll do some debugging.


Hi @Francesco_Veratti so the new system is more strict with images than the old one was, mostly because we were having issues with invalid images.

One of the icons in your screenshot that does not show is icon turismo as shown in the following screenshot:

Note that the image does not have an extension, it should read icon turismo.png. I downloaded your image, added the extension and uploaded it again, and now it works. If there is no extension, the system does not know if it is an image so it skips it altogether.

Note that simply changing the name of the asset by editing it will not work, you need to upload the image again with a proper extension. Could you please try that and let me know if that works for you? Thanks!


Thank you very much, I changed the icons and now I see them all. But I noticed another annoying bug. When I open the various screens, the background image appears and disappears, at times like intermittent. If you try to install the App and browse through the various sections you will notice the error. Can you solve it? Thanks so much
ps. I have already tried to rename the .jpg images/files but the problem remains. I think it is a Thunkable X problem in the creation of the apk