Potential issues with new data source blocks?


I am trying to publish a project using the new data component blocks. When I download the app to my android emulator (don’t have an android device), then try to save to submit data, and save to google sheets does not work. When I try this on the live companion on my iPhone it does save.

Is anyone working with these blocks in a published app? I will update when the download comes to my iPhone.

again, this does work on live preview. not on the download to my android emulator.

this does work in:
the responsive web app preview.
live companion app on iPhone
live test in browser window

does not work on:
android emulator
the published responsive web app

I could share my code if needed. but like I said, the app works in live preview. not on the downloaded emulator version

All help is appreciated. This is not a personal project, instead of a professional and the quicker it’s out to the client the better. Needing to publish quick!

I’ve moved this to the Github issues/bugs repository

I’ve tried to work around this issue. however, due to the auth requirements, i am not skilled enough to make it work :cry: I am at a standstill on this. The issue is that sending sensitive health info via by sending it to airtable first then moving into a HIPPA compliant google sheet with Integromat/Zapier is not ideal .

any and all suggestions/help will be appreciated


Sorry for the delay with this @jared - looking into this now.


Thank you @domhnallohanlon! I was doing the final test before presenting the app to the client :sob: (my day job employer)

Yikes! I’d recommend making a screen recording and play that on a screen if you’ve got a big audience. If anyone’s really interested afterwards you can give them an in-person demo on your iPhone.

Just following up on your GitHub, we installed and tested on an Android device and it worked fine. Wondering if the issue might be the emulator?

Also, wanted to confirm that everything is working as expected on iOS?

I’ll try again…

I’m wondering if you were able to test with my data source or if you hooked up your own?

Again, it’s strange that it works in previews but not published versions of the app. Does publishing remove api/oAuth access?

The Gdrive I am connected to is associated with a BAA and can be picky about who it allows access due to hippa rules. Maybe that’s a reason for the issue?

No luck with the published web app

If you want to test it the username is jgibbs@braintrustbh.com


Waiting on the iOS download