Mic and cam permission in webview

Hello everyone, I created my app using only the webview module, without any additional configuration.

However, Apple is rejecting it because the app is requesting permission to access the camera and microphone, even though my site/app doesn’t need this.

Where can I remove this permission request?

Welcome to Thunkable!
You may need to provide a good description on why you need to camera so Apple can approve:


(Please don’t write “IDK. Testing :)” That was a joke and will defiantly not be Apple approved…)
Note: You don’t need to this on Android

Thank you for the reply.

My app is using Webviewer and I dont need camera or mic, I think this is something default on Thunkable.
And about this Camera field, I cant see it.

You can only see it if you use a camera component within the app. Since its over webview, I don’t think it will pop up… So… contact Apple.

That what I was thinking, but they sent me this:


Oh, that’s normal!
That happens to every app when they ask for permissions.

You can still publish your app, correct?

I’m not sure

Can you explain it within Apple, not Thunkable?

Yes I know.

The main reason of this topic is about the permission.

Does the site in your web viewer ever access the microphone or camera?

No, at least there is no code asking for this.

Matt means, does the website use the camera within the webview?

1 Like

Yes, exactly this. Even if the components on the screen do not access the microphone or camera, as the end publisher of the app, you are responsible for the content and access that is requested from your end users.

If it turns out the site does access these, you can add in camera and microphone blocks to your app (they don’t have to do anything, the just have to be there) and this should trigger the permissions settings your app settings. You can add in the tracking descriptions from there.

1 Like

I found something on my website that might possibly require camera or microphone permission.

When the user selects to upload a profile picture, on a PC the files appear directly, but on an iPhone, more than one option appears, as shown in the image below:

To fix the problem, add a image, make the image invisible, then add these blocks :arrow_down:
image
Then this will pop up. Then fill it in :arrow_down:
image

Referenced from :arrow_down:

1 Like