ITMS-90338: Non-public API usage?

ITMS-90338: Non-public API usage i got a long email from apple on this
don’t think it is an issue i can fix

. Please correct the following issues, then upload again.

ITMS-90338: Non-public API usage - The app references non-public selectors in thunkablecompanion: callWithArguments:, createRequest, determineAppInstallationAttributionWithCompletionHandler:, estimatedProgress, frameInfo, identityToken, initWithFrame:configuration:, isMainFrame, isPassthrough, lookupAdConversionDetails:, navigationType, newSocketQueueForConnectionFromAddress:onSocket:, onSuccess:, removeValuesForKeys:completion:, setNavigationDelegate:, setProcessPool:, setRequestedOperation:, setRequestedScopes:, socket:didAcceptNewSocket:, socket:didConnectToHost:port:, socket:didConnectToUrl:, socket:didReadData:withTag:, socket:didReadPartialDataOfLength:tag:, socket:didReceiveTrust:completionHandler:, socket:didWriteDataWithTag:, socket:didWritePartialDataOfLength:tag:, socket:shouldTimeoutReadWithTag:elapsed:bytesDone:, socket:shouldTimeoutWriteWithTag:elapsed:bytesDone:, socketDidCloseReadStream:, socketDidDisconnect:withError:, socketDidSecure:, toDouble, toString, userContentController, viewManager, websiteDataStore. If method names in your source code match the private Apple APIs listed above, altering your method names will help prevent this app from being flagged in future submissions. In addition, note that one or more of the above APIs may be located in a static library that was included with your app. If so, they must be removed. For further inform

Can you provide some context here? Just seeing the message from Apple doesn’t tell us anything about your app. Did you make use of APIs? What type of components did you use (e.g. location sensor, maps, etc.)?

I’m not convinced this is something you caused to happen but it’s still helpful to have more details.

This has some guesses about the problem:

I am just updating my design no big changes to the version currently approved an in the app store i do have a webview just showing a site did not use any api location sensor, maps, etc. mostly just airtable info displayed

I’ve the same error here, even when I uploaded an empty project I got the same error

i reupload same project without changing anything and it went fine seems think apple was having issues

1 Like

I will try rightnow

Any updates @shrkaltd ?