Issues with component placement and alignment in the new UI

I really like the new drag and drop interface and I have been using it for a few days. However, whenever I preview my app via the iOS Thunkable app or by downloading it onto my iPhone, all of the screens are messed up.

When I preview my app, the images are squished and are scattered in random places across the screen.

When I download my app, sometimes my code just doesn’t run, while other times it takes a minute or two to respond. Images and buttons are also missing, and random white bars appear at the top of the screen.

Is anyone else experiencing these issues? Is there a fix? Please message me if you want more info. I can send some screenshots, as well as the project link.

1 Like

Hey @bobsunscreen - thanks for taking the time to leave feedback on the new UI, sorry it took so long to get back to you.

Yes please! This will help us better understand what’s going on and who to go about fixing it, thanks.

Labels that appear normal in the Designer come out stretched and grey during Device Live Test. Even buttons come out unnaturally stretched on a phone. Also, buttons that are perfectly hidden during web preview are seen in a totally different position on the phone. Because of that, I haven’t used the new Ui a second time.

Thanks for flagging this @codeswept - can you share a screenshot/recording of this behaviour?
Also, do you know if it’s unique to live testing or is it happening on downloaded/installed apps too?


also, pinging @bobsunscreen here too. If you get a chance please send on the screenshots/sample projects.

Thanks.

2 Likes

@domhnallohanlon,

The stretching doesn’t happen ALL of the time, but if you play around with size and position a little bit, you can make it happen

2 Likes

I just messaged you the link to my project and some screenshots and videos.

Thanks @bobsunscreen, will take a look.

Thanks @drted