Inserting count blocks does not change the index

Pardon me if this question is too simple.
In the below blocks you will see all count blocks has index as #i. I have tried all possible combinations. All of them continue to have #i. When I change the name of the index all the index name change. I dont see the option to change or generate a new index name.
However in the past I have added multiple counts and indices had automatically changed.

The only crude work around I know is insert a for block then I get #j. Then use the #j for the count block and delete the for block. If I need one more index, I rename #j as #k and then again insert a for block :slight_smile: keep doing it …
Please advice

You can create a variable and use it as a replacement for the “i” variable.

Btw why are you using loops inside a forever loop?
Usually this isn’t a good idea since the loops then runs forever,Wich causes your application to become unresponsible and crash.

Thank you for your reply. Yes creating Variable is a option but it does not look right. It comes with the word app i or app j. A long index name does not bode well. The thing is in the past when I added a new count block it automatically brought in a new index letter. Now that does not happen. Might be a Thunkable bug. The Forever I just gave as an example.

It could if it is a bug then you can report it on their GitHub page.

The “app i” variable has App in front of it because it’s a offline/app only variable.
This is to differ the variables from cloud and stored variables.

The key is to create a new function and give it an input variable such as “j”. The you can use that in your [count with] block.


Got it. Thanks @sketch and Tatiang. Will not file a bug

Finally I did solve this. The solution is insert a new Screen. Insert a count block in the new screen. It comes with #i as default. Then change it what ever you want. Copy that count to your desired screen. Delete the screen. Now I have count with i, j, k and I can keep going. Have filed a bug report too.

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.