How do i SET a buttons width size 100% in Blocks view?

How do i SET a buttons width size 100% in Blocks view?
I cant use the blue numbers blick as it not accept a % sign
And if i use 100% in a text box - nothing happens.
I guess, somehow it should work as its in the documentation
Please advice

It’s a common mistake to think that you can set all components with a single “set” block. You can’t. Try setting a single button’s width to 100% and see if that works. And if it does, you can then use the “all button in” block along with a list block to get the first item in the list of “all button in”. And then use a loop to get all of them.

But how do i set one single button to be 100**%** (rather than px - which is default) with blocks view?

I was just pointing out a problem with your logic. But I tried myself after that and I don’t think you can set the width of a button by percentage. You used to be able to, I think, by setting the width to any percentage in the button’s properties panel and then using blocks to change it to a different percent.

But because there doesn’t seem to be a way to set a button’s width to a percentage in the properties panel any more, I don’t think that method will work.

This will set a single button’s width to 100% of the screen width:

(Ignore the screen’s name… it was a demo for someone else)

This works for all buttons in a screen:

It needs the Wait block because the screen’s Computer Width isn’t available immediately when it opens. It worked for me with a Wait 0 seconds block. But I’d be sure to test it on various devices.

Aha ok…
Tricky thing this … Really…
What is actually “Computed” width mean?

And a little PS - Should not the Layout component (Beta) be possible to set to Screen Width and Hight in percentage ? No you can set Rows/Columns and Objects… but i am missing it for the layout it self…

I think it’s the width of the device’s screen rather than the Thunkable project screen width. See this: Get calculated width/height block - #3 by actech


So you miss that too…or… ;-D

I do!