Gyroscope Trouble

I am trying to figure our how to utilize the gyroscope feature but I am not sure if I am doing something wrong or if it is my phone that is not working. I have added a gyroscope to my scene and have tried a variety of things to try and get some result. Right now I just have the “when gyroscope1 changes” block attached to a label just to have it print something when there is some movement but even that does not work. Can anyone please provide some advice?

Hi @brad.strassburger

Is this while live testing or installing your app?

Are you on Android or iOS?

Are the Gyroscope docs helpful in any way at all?


I am live testing using an iPhone 5s. The docs are not really helpful as they indicate what some of the commands mean, but there are no examples to follow.

Got it - how about the simple examples here, do these work on your device:

This is not what I am seeing. When he adds the gyroscope block there are four elements attached to it (x rotation rate, y rotation rate, z rotation rate, and error). I do not get those when I add in the block. I think the video is showing classic.

Ah, I think the component has been updated since I made the video!

Can you share a screen shot of the blocks you are using please?

This is all that I have right now. Just trying to get it to recognize a change of some sort.

Sorry for the delay getting back to you @brad.strassburger - turns out these new blocks are documented in the release notes here:

I’ll try to get the docs updated by the end of the day (it might be in the system as a draft already?)

Sorry for the delay, kind of got side tracked. I copied to code exactly as it is on the document and it still does not work. So at this point I have to assume that it is my phone. I will try with an android phone later to see if I can get a different result.


Thanks @brad.strassburger, keep us posted!

1 Like

I tested on a second iPhone and it did not work. I tested on an Android phone and it seemed to work fine. So I am wondering if this is a feature that they have not actually worked out the cross platform issue?