Google Maps Error on previously working App

Pro User, just evaluating Thunkable for possible future use.

I knocked together a quick proof of concept app to show job locations on a google map.

It’s worked fine for months then maybe a week or so ago (I don’t look at this very often) it stopped working.

It has a single table data source with 10 rows of data. Each row contains a lat and long field. The rows are displayed in dataviewerlist. click on an item and it opens the map screen and displays a marker for current location and one for the job location.

Really simple and I was pleased how easy it was to do in thunkable. I’m busy working on the main system that will provide a back end for the mobile app so haven’t worked on app since I setup the original test.

I open it on the phone every week or so because… well mobile apps are way cooler than the boring backend I’m working on!! :stuck_out_tongue_winking_eye:

So for the last couple of weeks when I open the screen with the google map on it looks like it is going to display the map but then shows an error:

There’s more to the error but I guess this gives an idea of what’s happening.

I have not changed the app (there’s little to change as it’s only a test).

The only thing that I can think of as to cause is a software update on the phone. But how do I troubleshoot this sort of error?

Testing on Samsung S9 Android 10, One UI 2.5

Any Ideas would be great thanks.


The map function currently has an error and cannot recognize the Location Services status of the Android device and fails to read the location. The same function works OK on iOS.

@Thunkable_Staff @domhnallohanlon @jane

1 Like

Hi Muneer,

Thanks for the quick response.

Is this bug logged anywhere? Just so I can keep an eye out for updates on a fix!

I checked Github before posting and didn’t see anything.

I take it the bug is due to an android update!


It was just discovered two days a go. I’m waiting on Thunkable developers to decide if this is a bug that needs to be logged in GitHub or something that can be quickly fixed.

Appreciate your patience in the matter.


Thanks for the info.

It’s not a big deal for me at the moment as I’m only evaluating.

I guess it’s another part of the evaluation process to see how long it takes Thunkable to fix this kind of thing and if I can live with it.

Is there any history of Android/Apple updates wrecking Thunkable in the past?


Yes, yes.
This is not a single incident and Thunkable has a high response level compared to other platform.

Check this with Apple (this one is still work on progress)


Is there any update on this?

1 Like

I just tried it on a previously downloaded app and it is working now.


It is no longer crashing but Markers are not showing on the map.

The thing that concerns me most about this is the lack of visibility of the issue and lack of communication from Thunkable about progress to fix the problem.

I would imagine the google maps functionality is pretty heavily used in Thunkable Apps. I would have thought it would be a pretty high priority for a fix which is why the length of time this has been down is worrying. The crashing might have been fixed 5 minutes after I posted but I would have no way of knowing.

I’m only evaluating at the moment so it’s no big deal but if my app was in use I’d have been ******** for the last 10 days with no visible official recognition of the issue, and no clue if/when it would be fixed.

As a Pro User is there somewhere else I should be looking for this kind of support information.

How would I get this sorted in future if it was a major issue for my app?

It’s just made me a bit nervous of going forward with thunkable.

1 Like

First of all, if you have an already compiled app running on Android or iOS then it will continue to work correctly. The issue happened in one of the design libraries and it took them couple of days to detect and another one or two days to fix. But this issue does not effect already published apps.

As a PRO user, you will have contact with the support via email or via the chat bubble in the main Thunkable page.

Not sure what you mean by published!

As I mentioned in my original post this issue happened with an existing App already downloaded (via APK download not app store publishing) on my phone.

It was working one week then not the next! Hence why I thought it was due to a phone update.

I’m not complaining - I’m just trying to get a handle on what to expect if I were to use Thunkable for a business critical app.

I appreciate your responses to my forum posts have been very fast but I would have liked to have seen the issue logged somewhere that I could follow progress on.

As you mention I could have used email or Chat support and perhaps I would have had a better experience. But as a new user with a non critical issue (at present at least) I wanted to make sure the issue was not one of my own making - hence the forum post.

Is the marker issue I’m seeing a separate problem?

Please see one of the POSTS that complained and followed up.

The issue was very pressing and I have to admit I should have updated you but I forgot totally.

Maps are now displaying without error

However Markers are not showing!!

1 Like

Not sure anyone saw the second line on my last post!

***** Markers are not displaying on Google Maps component! *****

1 Like

A post was merged into an existing topic: Issues while using addIconMarker block

3 posts were merged into an existing topic: Issues while using addIconMarker block