Can't get to work cloud or stored variables

Hello. I am having a difficult time while using cloud and stored variables .

I’ve configured Firebase DB in my project, so I am able to authenticate and to use FirebaseDB (get and set FB variables).

However, for some reason when I use a cloud variable or an stored variable on my applicacion, app seems to stop executing the block (and the next blocks in the same event) after any reference to cloud or stored variables.

I remixed Gram example with the hope that I were doing something wrong in my code, but it still doesn’t work. If I remove all references to Cloud and local variables in the blocks then everything seems to work fine :frowning:

This happens on both iOS and Android, and the original Gram code runs fine on “preview”, but not when I remix it :frowning:

Any hints?

Hmm… I’ve just realized that even app variables doesn’t work :confused:

Please see this screenshot:

1.- When screen starts, lbl1 should be “b” and lbl2 should be “d”. However, only lbl1 is updated to “b” (execution stops when assigning to local variable).

2.- On, only lbl1 is set to “e” (note that it should be “f” after reading app var1).

I am a bit lost… what am I doing wrong? In Thunkable classic variables work perfect to me.

Can you share your project please ? Everybody seems fine :confused:

same problem here with cloud variables, and sometimes stored :frowning:

Sure. This is the link:

I’ve removed Firebase key and URL, and changed variable from “Cloud” to “Stored”.

Just mention that it suddenly started working on iOS this morning, but still dont work on Android (I’ve tried three devices and reinstalled thunkable companion just in case…)

Thank you !

Well… I don’t know really what happened, but some minutes ago it started working on both iOS and Android. Even on the devices it didn’t worked previously, with the same projects it failed yesterday (no modifications on API Keys or blocks).

I’ll keep an eye on this and will update if anything new arises.


Happens to me all the time, it takes a phenomenous amount of time to update, that’s why I suggest you directly install the app which gives you a better representation. Glad it worked :slight_smile:

Thank you AcrobatEpee :slight_smile:

There has also been a recent update which claims to fix variable bugs, all is working well for me now!