Bug on Database list showing?

Hi there,

I’m struggling on something really, really easy and it is taking me so much time to solve, i guess this is a bug.

The app is meant to give some options on quotation depending on the lenght of a surface.
Example, if the surface’s lenght is between 1000mm and 12000mm, it shows all the possible solutions.

The problem is that, when on blocks, i create a database for each of the solution that can be easily read. Sometimes tho not all the options are shown. This is the example (one of the examples as it happens very often with no reason also with other numbers) of the blocks:

This what happens, the list is shown under “Aperture disponibili” (Available solutions):


Instead of showing the 3 options:

  • 7 Ante Apertura Laterale
  • 10 Ante Apertura Centrale
  • 12 Ante Apertura Centrale

it just shows 2 of them - as said, it happens also when i put other values.

What i have tried:

  • i tried to delete the blocks and write them again
  • i tried to put just a simple number instead of a math formula
  • i tried to change the name of the values - it changes the name but always missing one row
  • web previewer, same error

The value “Altezza” doesn’t have any incidence in these blocks and, at the end of the “if-else if” section, it refreshes automatically the database/list.

Even stranger, when i get back to it, after i closed the live or the web previewer and then i open them again, it shows me everything correctly.


But if I try to insert the numbers again, it will always miss a row.

Any idea why is it happening?

Nobody experienced a similar issue?

Can you try the refresh dataviewer block as the last in the sequence

1 Like

Hi Jared,

I dont know why the “Refresh Data” at the end of the blocks wasn’t enough, i had to put it twice as you said.

Thank you very much, mistery solved.