Bluetooth 'Read Failed' Error, (iOS 13.1.3?)


For the first time I am having issues receiving BLE data. On some phones it receives fine without any issue, but on others I get this error message:

“Characteristic … read failed for device … and service …”

The problem phones have all been running iOS 13.1.3. Is there an issue with this update?


1 Like

Here’s the block in question, it’s not the issue here.

You have to build the app and install it, not use the live test. :wink:

1 Like

Yeah I know, it is installed. And as I said it had been working for months until recently.

So anyone from the team have any advice? Are there any known issues with iOS 13.1.3?

  • It’s running fine on all phones that don’t have iOS 13.1.3, but it’s not working on any that do have 13.1.3.
  • It was previously working on the same phones until they updated to 13.1.3, when it stopped receiving data
  • The data is received from an ESP32. I’ve tested multiple ESP32’s with a range of phones, it works on all except for those running 13.1.3

They can still scan, connect and transmit, but cannot receive.

Seems like I’m talking to myself but I’ll continue, hopefully I can get a response.

Same issue on iOS 13.2. Devices can scan, connect, and transmit but cannot receive BLE data.


@domhnallohanlon @Mark @jane

@myusername do you also have your location sensor enabled?


Hello, check my topic: iOS app with BLE Component is not able to connect to a device via Device Name [solved]

1 Like

@domhnallohanlon Yes I have the location sensor turned on

As I said it’s been working for months. Literally the only change is the iOS update.

ah, understood.

I’m still on 12.x for the moment - will get the iOS 13 update and take a closer look at this.


1 Like

@domhnallohanlon Great, thanks.

Hopefully it’ll be fixed soon given iOS 13 has been out for 6+ weeks now.

Its not working in Android too.

Yeah I just tried on a Samsung Galaxy Tablet 2019, same thing: can scan, connect, transmit, but cannot receive.

@domhnallohanlon any updates? BLE seems almost unusable at the moment on a range of devices.

The only devices I can get the simplest of receive BLE data blocks (that I posted above) to work on are iPhones/Ipads not running iOS 13.

Bump. @Domhnall @paulmw @Mark @jane

It’s been nearly 2 weeks since I posted this. Can someone give me an update please.

Or if fixing this isn’t a priority, please just let me know so I can stop wasting my time and money. Thanks.

I mean this is absolute basic functionality. I’m just trying to receive BLE data.

This is an example of an app that works on some devices, but doesn’t receive data on a whole range of other devices.

Sorry again for the inconvenience @myusername

Which devices does it work on? Since there are so many variables here in terms of BLE hardware and device hardware it’s difficult to reproduce this issue and diagnose what the root cause might be?

@domhnallohanlon As I said above, it works on any iPhone/iPad not running iOS13.

I’m yet to have it work on any iOS device that is running 13. It’s also not working on the 1 Android device I’ve tried so far (a Samsung Galaxy 2019 Tablet running Android 9).

So there’s issues with a range of devices. Same error each time, can’t receive data.