Air Table data seems to be cached and showing old data

Before I start copying and pasting a bunch of pictures into this thread I thought I would just ask the question first. I’m adding the ability to update some data stored in Air Table to my app. When a page opens it will call a function that will pull back data from Air Table if a var contains a row id. This was working just fine until I tried to do an update. I can update the data just fine. When I go back to the previous screen I refresh the data in my data viewer and it pulls down current data just fine. The part I’m having a problem with is that when I click on the row to update and move to the update screen it should pull down the current data based on the row id passed and it kind of does this. The data it pulls back seems to be old. I can confirm that the data has been updated in Air Table. Technically everything is working just fine but the display of the new data is not working right.

1 Like

OK, interesting. This actually has nothing to do with Air Table but it is some issue with the testing app for the phone. If I kill off the app and restart it the data is correct. Apparently the app is somehow caching the data. So how do I fix this? Or is this just something to live with and the actual all will work ok?

1 Like

This happens in both the Preview option and in the Phone testing app. For some reason the Live View will not work correctly for this app?

1 Like

Bugger. This also happens in the complied app that I just downloaded and installed. Now I’m a but stumped?

There’s a known issue with the Thunkable Live app not updating:

But that should not be the case in a downloaded app.

I wish that was the case but I’m seeing the same issue happen in both the testing and download apps.

I added an entree into that bug thread. I have confirmed that this is also happening in the compiled Android app. If I close and then reopen the app, the data is current. This makes using the product with regards to working with data rather tough. Kind of a shame :frowning:

1 Like

are you using data source block to pull airtable data?

I’m using the data view method where I attach the Air Table as a data source. But I do not see how this would matter since rebooting any of the applications shows current data. Plus, I’m seeing correct updates in the actual Air Table. So, technically everything is working but the app is caching and showing old data.

The same problem with the installed application

if you using data source block, it already reached thunkable staff and we have reported the issue. i have similar case where airtable not updated when i using data source block.
for solution i am using airtable block it self and worked perfect.

1 Like

OK thank you. Yes, I have also added a post to the reported bug regarding this issue. I’ll check out the Airtable block.

1 Like