Some data source blocks not working

Interesting…can you try moving those blocks to a button click event rather than the screen opens event?

1 Like

Same result.

What is really interesting that once I change the tables names to domhnal and muneer, everything works OK.

Oddly enough I tried swapping to what you had in your screenshot and it still works fine?

Screenshot 2021-05-18 at 17.25.18

I wonder if it’s an issue with multiple sheets?

Can you try with just P1 and see if that works?

1 Like

I created a new sheet with only one table and new project but I got the same result. The data viewer shows the values but the list viewer does NOT.

In both the button click and the screen opens events?

1 Like

I changed the table name to P1P1

See the outcome


I made another test. I like to test every possibility and thought is it connected to a pattern such as a letter followed by a number (P1) and will work if it is different?

So I changed the table name to PR instead of P1.

Guess what, it works fine.

Can you confirm from your side? Create a sheet with one letter followed by 1 or 2 numbers and test if the list of values works.

:thinking: so, when I change the name of my sheet I can’t sync with the data source…

1 Like

You will need to delete it and create the data source again.
You will have to bind it again with the data viewer and reconnect the code (You will not be able to view the code screen from first attempt) but this is hardly an issue.


You have to delete existing source from the My Data Sources tab. It will not work if you delete it from the project.

I now have a sheet called pi and a sheet called k9 with identical data, but sorted in a different way.

The alphanumeric sheet names aren’t working :cry:

For the time being can you switch to a different naming system?

1 Like

It wasn’t me. I was responding to issues posted here in the community and found out that some blocks doesn’t work.

@bnice - are you ok working with slightly different table names for now?

We’re looking into this at the moment and I can let you know more if I find out any more about the root cause.


1 Like

Yes, I already renamed my sheets. The names of my sheets are flexible. My sheets were named after Chromebooks, so I just added the brand name to the beginning of them and everything is working great at the moment. (Ex. ‘N22’ went to ‘Lenovo N22’) Thank you for looking into this. Hope we can find a solution!

1 Like