[Solved] How to disable swipe navigation?

In this project: https://x.thunkable.com/copy/f2bf4cbd353ec12aa9e78473e9537424

I have a splash screen with a 3 second timer, then it navigates to the home screen. However, if you swipe from the left edge of the home screen, you can navigate back to the splash screen. How does one disable this swipe-to-navigate behavior?

To create a screen splash use the Tab Navigation component with the swipe mode disabled and the hidden tab area. Example by reference.

https://x.thunkable.com/projects/5b289b7732738c6979cf98f4/project/properties/designer/

For some reason, that link is just pulling up a blank page for me.

Sorry, check out this link.

https://x.thunkable.com/projects/5b292361ba824521d3d43a43/project/properties/designer/

No problem. Your example works but I am having trouble figuring out how to hide the tab area. Where is that setting?

Thanks for all of your help, actech!

1 Like

No wonder I couldn’t find it! I was looking in the wrong place. Thanks again!

edit: Please disregard

I can’t find the TabBarVisible option in my project. Is this only for android?

@maptheunknown you will only see this option if you screen is inside one of the tab navigator components.

If you look at the Screen1 component in the screenshot it’s underneath (and inside) Tab_Navigator1

1 Like

I don’t have that option :frowning:

Would you know why?

Here is my screenshot:

This is the screen properties,you may go to the navigator options?

1 Like

@maptheunknown

To go to navigator options, click the top_tab navigator1. (just below scrn_splash)

Thanks! :blush:

Am I missing something here? I still cannot see the TabBarVisible option.

Here are my screenshots:

Hi, @maptheunknown

Try to go to the advanced tab.
I think you will find it there :slightly_smiling_face:

Thanks! :blush:

1 Like

This is not more working… I think need a solution

I have one splash screen when i open it decide if it goes to the main page if login if not it goes to login page but I still can swipe back to the splash screen…

Make sure this splash screen is not in your navigator and you won’t be able to swipe back to it.

1 Like

Still cannot find TabBarVisible option. Even in the Advanced tab. Help!! :frowning:

Best regards, Alex
ACtech demo project
Thunkable X Basic Programming Course
Block Reference
Component Reference
Bug tracker

2 Likes

I can see it using a Bottom Tab Navigator but the Bottom Tab Navigator doesn’t have the SwipeEnabled. When I use a Top Tab Navigator, I can see the SwipeEnabled option but I cannot see the TabBarVisible option. How can I disbale the swipe and at the same time hide the tab bar?

Here is my screenshot for the Top Tab Navigator

1 Like