[Solved] Get property from JSON object


I am new to this today. I started working on this tutorial. It grabs "advice from a site and becomes a random advise generator.

However, because there is no text to speech component to add to my app, I am not having luck. I have found the “speech” blocks, but It just returns “null” guess I am not using them correctly. Any ideas?


1 Like

I’d try changing a label to the value of ‘app variable advise’ to confirm that you’re getting what you’d expect going into the “say” block. I’d also set other labels to status and error, in case there’s something not right there.
Debugging APIs can be tricky, and its not clear if the problem is what the API returns, not anything to do with the speech block.

I’d also try JUST doing text to speech with some static text, to make sure that’s working. Currently, playing recorded sounds in iOS is broken. I don’t know if that extends to the text to speech block or not, so it’d be important to make sure that text to speech is working in a simple case, before trying to debug the complex case.

1 Like

you are right. When I set this to change a table, it simply prints null. Strange. I worked this out earlier on the older setup and It worked fine. switched accounts and selected the new drag and drop and now it will not parse the data correctly?

I am new to this so I am sure I am doing something wrong… I will keep at it.

thanks again for all your help today :slight_smile:

1 Like

So what is the full response, error, and status?

You need to spell the property name as “advice” since the JSON response uses that spelling:


good eye, @tatiang

1 Like

:raised_hands: :slightly_smiling_face:

Spelling For the Win!

Ok, I dumped it so I will rebuild and post my results :flushed:

The spelling was the issue. Thanks so much for your support in my learning!

1 Like