Maps component doesn't work in compiled Apps

I have the following problem:
I use the map component to show in an app a simple map centered on the current location with a star-shaped marker.
Everything works correctly in live test mode on both Android and Iphone, but when I run the same code in compiled form, it displays the Thunkable splash screen and the app crashes instead of the map.
I’ve obviously entered the Google Maps API correctly for the compiled version, but I don’t see any requests coming in towards Google Cloud and the smartphone doesn’t request permission to use the location, which it does when I go into live-test emulation. This makes me think that the compiled application crashes before making the call to the Google Maps API.
Tried on several Android phones of different brands. Same result.
Is there anyone who has encountered the same problem and has a solution?

I also tried the simplest possible app, putting a map in the center of the screen and that’s it.

I tagged the test app as “public”, so anyone can open and check:

Side Note: this problem happen only for apps edited with the newest DnD interface, apps created into the “old” user interface work perfectly even compiled.

Here the URL of the same app edited in the old environment

Thank you.

Hello :wave: @pierluigi.zerbinia9 Welcome to our community!!!
Thank you for sharing your project URL. I appreciate you taking the time to do so.
It doesn’t seem to be an issue with the map component. I tested another app and it was working.

Thank you for this reply Ioannis,

So, you tested a a map component into an app, using the new editing environment and worked?

As i told you i tested several different devices/android version obtaining always the same result:

the app “crash” showing the thunkable logo.
Could you please try to compile and run my test app:

and tell me the result?
The app i s very basic, just a map component in the center of an empty screen, but crash.

Also detail about the phone used to perform the test could be relevant/useful.