Making a Search Bar

I want to make a simple search button but when I open the link there are so many buttons we can’t understand which code is for the search button so someone can help me pls

This is an example of a simple search using the new data viewer. See the table in the project to know what to search for. You can also add to the table and test.

1 Like

dear Muneer
thank you
i am very happy with your work you give me answer in just 15 min

1 Like

Glad that helped you

1 Like

too slow to show result… i have 1500+ locations… and take 5 seconds to show filter result… too slow in Thunkable live while testing and developing… take 7 seconds in a compiled apk

1 Like

You can optimise the code to make it faster.

I used the already popular method by slightly changing it. I think the result is also very good.


Why it is not working for my case… This data includes 234 Row and 11 Column. (Pills ingredients)

I have switches for different datas search. indications, contraindications, etc. for search.

1 Like

I guess that’s why :slight_smile:

1 Like

it is my mistake but it is not working still…

Same blocks working another screen another datas (thats small data i mean rows and columns less than this one. Is that possible to about for row numbers and columns numbers)

1 Like

Define the variable “entreList” only once not on every text change

No sir it is not working you can check more our block. I changed little one block

are u using thunkable live? try to clear data or uninstall the app, and re install again… sometimes their cache system doesn’t update your block that makes too hassle

dear munner
I am so glad to contact you second time
i want to ask that i want to take thunkable pro i want to pay monthly and $25 is much for me
so i can pay $17 monthly if you can so give me off

thank you
sanvee khare

1 Like

please help me

1 Like

I am not working with Thunkable and I paid for my PRO account like every other PRO member.



sorry it a confusion


1 Like

Please send the copy of your search app

I tried this so many times, yet it still isn’t working for some reason

I tried the same code and it didn’t work for me