Internal error when adding polyline from variables


I am trying to create a route in a map in Thunkable X by gathering coordinates every N seconds, and then painting a polyline on the map.

However, I’ve found that when I use variables inside the “addPolyline” method, I always get an internal error. Please see screenshot below:

I can create a list from variables, but the error happen when assigining it to addPolyline.

Things I’ve tried before posting:

  1. The one on the screenshot.
  2. Creating a local variable with the fields “latitude” and “longitude” and assigning to addPolyline directly.
  3. Serializing and unserializing this last local variable.

None of these 3 approaches worked.

Is it possible to create a polyline from variables? if so, is there any example available to check what am I doing wrong?

Thank you !

1 Like

I have the same issue with new variables (since the update). In my old projects it still works.

Use old type variables that can be obtained from the function block to which the parameters are added.

Thanks for reporting this bug. It will be fixed in the next release (and thanks for the screenshot, it helped to track down the problem quickly).

1 Like

I created new variables and it worked —