YAIL Compiler - DX Execution failed

Hi,
I’m trying to compile my app but I get this error:


This is my aia: School_Life_Diary.aia (1,3 MB)

Please help me solve this!
Thanks

Did you take a look at this


this

or this

???

Yes… but it doesn’t work…

How many extension do you use?

Just… a bit…

I think this is the problem, you must reduce the extension, use just the important extension for your app…

I use all the extensions…
I can delete only TaifunGoogleAccount and WebVieverDialog, but the others I use all…

Just try to delete that extension first (TaifunGoogleAccount and WebVieverDialog) , and then try to export your apk again… l hope it help

I tried to delete them but I got the same error…

Did you update some of the extensions?

Not recently… I think some weeks ago…

can u check de blocks if some changue? , I have the same error , was the creator changue one of ther blocks and cause the system fail

You cannot use ExtraComponents and Dialogs extension together, this is a wierd bug.

But ExtraComponents is the only way to obtain background colored buttons with Material Design characteristics…

@ILoveThunkable @maicol07 Backup your project , download de aia , in the copy delete one of that component if u can build Is that ,

Problem is not that. There is a wierd unknown problem, when using both these extensions. You have to import either extra components or dialogs extension.

So only one is permitted? Is a bug of Thunkable or of App Inventor in general? Also has WebViewerDialog the same problem?

actually it’s not a weird unknown problem, it’s a very well known issue and I suggested to @Helios several times how to fix it


it looks like @Helios is not very much interested in doing this…
Taifun

Oh, didn’t know that. Thanks for the info.

So are you going to fix this? Has Dialog Webviewer the same error?