WebView err_access_denied

webviewer

#1

I’m using the translator

Today I went to package my project in APK, and I’m getting this message in all my WebViews. I’ve done a lot of tests and it continues. I opened a new project and did something pretty basic like pulling an image, but the message keeps popping up. I used AppyBuilder and there was no problem. I’m using Thunkable BETA because of AdMob. In all my projects is this error happening, do you know it can be, or is it temporary?


#2

It would really help if you provided a screenshot of your relevant blocks, so we can see what you are trying to do, and where the problem may be.

Taifun


#3

The beta WebViewer was updated yesterday so this is possibly the source of your error. However, I had no issues yesterday when testing, nor today when I rebuilt my test project so I’m not convinced.

Here are some pointers for wording your next post:


#4

Could you test to see if you are receiving this error on the main server (app.thunkable.com)?


#5

This error is giving. I tested it in the normal version and it worked correctly. But I wanted to be able to continue using the BETA version and I’m afraid this update would go into the normal version and cause me a headache.


#6

the webviewer is only able to access files in the assets of the app or in the internet , but does not have access to the file system (after building the app)… you will see the same behavior in App Inventor, Appybuilder and Thunkable…

see post below how to fix that

Taifun


#7

My God. And will not there be a way to circumvent it, or something?


#8

But it could be fixed if the app requests access to the SD Card or Internal Storage, no?

It would be possible to request access to the files using an extension?


#9

I just tested it… the problem is the missing permission android.permission.READ_EXTERNAL_STORAGE in the webviewer component.

so if you add a component, which requests that permission (this could be for example the file component or the file extension), then you can access the sdcard

Taifun


Url & google maps error
How many files can be uploaded to a project?
#10

But is there any way we can have a duplicate part of the WebView component as an extension? And have that permission? Are you capable of anything Taiufun?
After I spent one night analyzing the problem, I was able to get it up by moving the HTML to the assets and inside it having a JavaScript that pulls my data, but the way to read through SDCARD was a lot better.


#11

Are you using Android 6+? If you are make sure the permissions are enabled/allowed.

Settings -> Apps -> <app name> -> Permissions


#12

@Taifun is right, you can just put the file component into the app (do nothing), you will have the app working…


#13

But I already use the File component, and it does not work, but I’m going to do a test here, and I think it changed in Thunkable BETA, because today it worked without giving this permission error.


#14

atttached please find a test project…let us know, if it works for you
a) in the companion app
b) after builidng the app using the apk file

webviewer.aia (30.7 KB)

Taifun


#15

@Taifun the Beta server was updated today and it looks like the issue is fixed.

p.s: the Import legacy app project only changes the package name of an app, you only need to use that option if you want to keep the appinventor_ai package name. Selecting import app project just changes the package name to com.thunkable.android...


RSS feed worked in 2014. but not now, why?
#16

ok, thank you… :wink:
Taifun


#17

Please the path to access the files in the webview are no longer working what would be the new path and urgent


#18

@Ezequiel_Daguano read the posts above.


#19

I put the file component here and continued giving the same error


#20

Even by placing the File component the error continues. And to make matters worse, with the last upgrade Companion is not giving to access the folder Asset!