The blocks area did not load properly. Changes to the blocks for screen 6271615010603008_Screen1 will not be saved


#28

how many blocks do you have on that screen?
how many different components are you using: labels, textboxes, buttons, etc.?
Taifun


#29

Hola Taifun, te cuento que cuando me aparece ese problema, empieza a fallar con todas las app, es decir tanto al crear una nueva app, que se encuentra vacía sin ningún elemento en la pantalla, como con una que tiene una sola pantalla con un solo botón o con otra mas compleja con varias pantallas Y hasta ahora lo único que lo soluciono fue recargar la pagina del navegador.
Saludos.
Robertone

Translated by Google:
Hello Taifun, I tell you that when I see this problem, it starts to fail with all the app, that is, both when creating a new app, which is empty without any element on the screen, as with one that has a single screen with a just button or with another more complex with several screens And so far the only thing that solved it was to reload the browser page.
Greetings.
Robertone


#30

I have same problem, I try to remove the last extention was added and its work…


#31

If any of you are desperate to get your aia working again, I was able to repair my program by downloading the aia, extracting the archive as a zip, and manipulating the source files. I carefully transferred over the .bky and .scm code piece by piece into a duplicated project with the problematic screen deleted. In the end, none of the xml code from the .bky files needed to be modified with exception of the new screen name. I’m not sure why Thunkable was treating this screen as corrupted. Perhaps it’s a bug of some sort.

Found out the aia is a zip here: https://appinventor.pevest.com/2015/04/03/what-is-inside-a-aia-project-file/


#32

I am desperate here - I did not expect my source code to be totally unavailable just like that…

The majority of my algorithm for a large app is gone since it was in screen1. I cannot update my app for Google Play Store anymore - it is essentially dead.

Please Thunkable - when will it be fixed?

How can I get my source back?

Please…

/lars


#33

I hope you have made backups?


#34

Oh well - I have. Does not help much when the Thunkable guys change the internal workings of the development platform in ways that make loading and compilation impossible. Seems to be no focus on configuration management.


#35

I think this is not fair. The reason for this can be very divers. If you search the forum you will find many topics. Most of the time users use images that are to big or are reaching the max of the number of blocks. (Max is not a fixed number).

See this topic


#36

In principle I do not agree. Every addition to a platform should be backwards compatible. If this is not possible configuration management must be applied or conversion tools made available.

However, I acknowledge that this is not a professional platform for commercial use.

Great for educational purposes though.


#37

it seems to be, you learned the hard way, how important it is to do backups…
see also the reasons here http://twodogapps.com/?page_id=686#BackupWork

Taifun


#38

As I said: I did backups. They won’t load properly today.

But never mind - I was able to load and inspect the previous version even though it cannot be edited. The most recent version had no blocks in screen1 when it was opened.

I have recovered my algorithm by doing screenshots so I can move on.


#40

Hi,

Since yesterday i have the same problem on all my applications:

The blocks area did not load properly. Changes to the blocks for screen 5052425073852416_Screen1 will not be saved.

When i create a new project, i have the same error, is there problem on server Thunkable or with my account?

Thanks
Best regards


#41

Hey @Julianinho,

Sorry to hear this - we haven’t updated anything on Classic recently so I’m not sure what the cause is.

I know you’ve been using Thunkable for a long time, so presumably you’re using the same browser/computer/ etc?

Does the error persist if you try an incognito window too?


#42

Hi,
Thanks for help :wink:

I test now with incognito window and I tell you if it works.


#43

Hi @Domhnall

I have try with incognito window on firefox, i have try with chrome and same problem.
It weird because it does it too happens when I create a new project


#44

Strange! I just logged into my account and I didn’t get any warning - let me look into it and I’ll get back to you.


#45

Yes is strange ^^

I thought maybe there was an application that is problematic and would bug other applications?

let me look into it and I’ll get back to you.

Yes no problem, I’m waiting for your feedback

Thanks


#46

Hi @Domhnall

I did some tests, I do not know if it can help you

  • I downloaded the project (which had the error message) in aia file on my pc.
  • I recreated another thunkable classic account with another email
  • I have uploded the file aia in the new account thunkable and I do not have an error message.

I will do this on all my applications to import and see what it gives, but I could not keep my new account because the package name will not be the same

Best regards


#47

Thanks for the update, every bit of information helps.

I’ve escalated this to our team, I’ll let you know as soon as I hear back from them.


#48

Thanks