Testing with USB (solve this problem)

beginner

#1

some one help … when i test by usb it shows "The ThunkableStarter helper does not appear to be running Checkout here? "
My all drivers are updated …And I am using usb test in appybuilder but why i face this problem in thunkable ?..


#2

please help


#3

Please help anyone …:pensive:


#4

Does the path to Thunkable Starter have spaces?


#5

Even if it was running, sometimes it wouldn’t work with your phone


#6

Sorry what do you mean by space (i should move starter to c drive ?)


#7

Space in path like C:\User\Hello World\ThunkableStarter.exe (Notice the space between Hello and World; it should not be there)


#8

Thanks solved my problem …


#9

Thanks mate


#10

I know this is an old issue, but I had an issue where the debugging worked once and then it would no longer. I had to open task manager and kill adb.exe. Thereafter USB debugging worked fine.


#11

The following solution really solved the problem for me:

Updating the ADB driver from the device manager. Find the hardware ID first
by going to properties of the ADB device in the device manager. Then copy the ID
and put that in google in order to find the right driver. Download the driver and from
the device manager (ADB device) , install or update the ADB device driver for your smartphone/tablet.
Restart your PC and start the Thunkable Starter software first for USb testing. Then do the usb testing
from within the Thunkable online software (browser). It should all work now…it did for me anyway…
See the explanation in the video here that I found on youtube:
https://www.youtube.com/watch?v=KcJ-8axeH4A

Cheers!
Johan