[Solved] What happened to the positioning?

Toda, I made a very basic app with just a text-input. When I live tested it, even though it was center aligned in the Design tab, it turned out to be at the top-left, stuck to the corner. What happened to the positioning?

1 Like

I had a similar problem. Thunkable Time, have you released a new version?

1 Like

I discovered that the property “alignSelf” was changed/deleted by the system. I returned the property “alignSelf” to “center” and my interface returned to center.

I don’t think I’ve veer seen the AlignSelf property: where did you find it?

@codeswept yes, we had a couple of updates recently. Are you using the drag and drop editor?

@caminostudio you mention “align self” so I assume you’re using the legacy editor?

It’s in the advanced properties tab of the legacy editor

My design screen looks like this

This is my Preview screen

And this is the responsive web app

Why is this happening

This is happening in a project my student is working on, too. He only had a single button in the default center position and hadn’t changed any properties (that I’m aware of). This was in the legacy interface, not drag-and-drop.

It just started today so I’m curious what might be causing it.

Could this be your student’s issue

1 Like

Just tried to replicate this issue on my end and wasn’t able to - after taking a closer look it seems that this was picked up on last night and our engineering team have fixed the issue already.

Thanks for taking the time to report this and apologies for the inconvenience.

cc @codeswept @caminostudio @vatsal @tatiang @muneer


Nope, I’m using legacy.

Edit: Missed your last post- great to know ou fixed it

Thanks @domhnallohanlon! Working fine now! And now (last version) a don´t have to set the advanced property “alignSelf” to center. The standard property “Horizontal Alignment” set to center now works. Old bug fixed. Great! Thanks!!! Bye!

The label is invisible and only the border is seen.

The positioning is okay but the label is not seen at all.

The label width is set to “Fill container”? Maybe it is related to another bug reported “Label disappears when the label width is set to Fill container” (Label disappears when the label width is set to Fill container · Issue #785 · thunkable/thunkable-issues · GitHub). I reported this bug in December, but it is still open.

1 Like