[SOLVED] Thunkable App released to Google Play is asking certain users to 'enable' / 'activate'

google_play
troubleshooting

#1

We released our first Thunkable Classic app to the Google Play store a few weeks ago. First tests showed promising and the app appeared to work pretty good.

But yesterday, we got some notifications from users, that after installing the app via Google Play, a button is being displayed to ‘enable’ / ‘activate’ (button is in dutch and says ‘inschakelen’, which can mean activate or enable). Pushing the green button ‘inschakelen’ appears to do nothing. Was reported by 2 users so far.

Tried searching both in the Thunkable documentation, the forums here and via google. But I can’t find anything. Who knows what can be causing this? Which other info should I request to speed up the troubleshooting, besides android version, phone brand/model, etc?

Added the screenshot of what the end-user sees:

Cheers,
Melle


#2

please switch your device language settings to English to get that window in English and post it again
Taifun


#3

Hi @Melle,

What does your app do? Is this a permissions or privacy requirement that is specific to the Netherlands?

Perhaps @Peter_Mathijssen might be able to shed some light on this?


#4

I was thinking that it could be related to the gdpr law in the eu. You are asking that users should register within the app. Maybe that is causing it.

I installed the app to but didn’t get the message. It would be interesting to know what phones the people use who reported it.

I have a Nexus 5X and didn’t see it (yet :wink:)


#5

Unfortunately, we cannot reproduce it and it’s happening on the phones of external users. We have asked for feedback / switching language, but no response yet.


#6

@Domhnall The app basically loads our AngularJS mobile responsive website into a WebViewer. There the user is requested to login, and can then go through a web flow to select a specific topic + enter a postal code. Select from one of the matching support organisations and either lookup their info or send in an info or contact request for themselves or their clients.

As far as privacy, we should be fully GDPR compliant. We have a legal and privacy statement, both verified by proper legal authorities. And software is also already running on tablets and other user their phones. Seems to be a very small select group of users where this is happening.

Could it be some kind of (company) policy causing this?


#7

@Peter_Mathijssen no registration is not activated. User get accounts handed out and can their download the app and login. So that cannot be the reason. Plus, other users also installed it, logged in and are using it without a problem.

I have requested more info on their types of phones / models / android versions. Good to hear it installed properly on your phone. I also have the Nexus 5X (which is getting slower and slower, but it works) :smiley:

I’m starting to think it’s some kind of strange (company) policy on the phone perhaps, preventing the installation from finishing.


#8

All, just wanted to inform you that the issue was related due to a typo made in a whitelist policy, handled by their application management department of the organisation using our app.

So if this issue arrises, make sure to ask the user if they use a work phone and if there is a department responsible for handling/authorising app installations / access.

Gave me quite the headache this, but happy it’s finally resolved.

Cheers,
Melle @ KOPPL