Pick Google Account extension and AdMob component are incompatible

how did u corrected it plzz tell me
m also have exactlly same problem

Didn’t you read Taifun’s answer…

their is no warning in my blocks

this is shown while compiling

Thunkable is unable to compile this app. The compiler error output was ________Preparing application icon ________Creating values xml ________Creating animation xml ________Creating fragment xml ________Generating manifest file ________Attaching native libraries ________Attaching component assets ________Attaching ttf files ________Attaching project-info.txt file ________Compiling source files (compiling appinventor/ai_errorfoundteam/Go_learn/Screen2.yail to appinventor.ai_errorfoundteam.Go_learn.Screen2) (compiling appinventor/ai_errorfoundteam/Go_learn/Screen4.yail to appinventor.ai_errorfoundteam.Go_learn.Screen4) (compiling appinventor/ai_errorfoundteam/Go_learn/Screen5.yail to appinventor.ai_errorfoundteam.Go_learn.Screen5) (compiling appinventor/ai_errorfoundteam/Go_learn/Screen1.yail to appinventor.ai_errorfoundteam.Go_learn.Screen1) (compiling appinventor/ai_errorfoundteam/Go_learn/Screen3.yail to appinventor.ai_errorfoundteam.Go_learn.Screen3) (compiling /tmp/runtime863448526280904837.scm to com.google.youngandroid.runtime) Kawa compile time: 2.711 seconds ________Invoking DX YAIL compiler - DX execution failed. .

then your issue isn’t the same as above, do a search for DX execution failed


Taifun

it starts compiling when i removed push notification
but now it giving same error when m adding admob to it

when m using ur google account picker extention its not allowing me to include admob

thank you, I now added the AdMob component into the list of incompatible components for the Pick Google Account extension here https://puravidaapps.com/accountmanager.php#pick
Taifun

it’s still not working
vnfgbhjcd.aia (367.4 KB)

and it never will work

Note: In Thunkable you can only use this extension in case you are not using a component, which already uses the Google Play library, i.e. for example the Google Maps component, the One Signal Push component or the AdMob component!

Taifun

I think this issue is related to Thunkable having ID issues/bugs with their elements using the Play library… For example you also cannot add 2 of the same elements (Google Map, AdMob,…) because of that -.- wonder if they are ever gonna fix this because they know about it for quite some time now and nothing happened unfortunately :frowning: