thank you for your contribution!
Please also follow the naming conventions, which is UpperCamelCase for property, method and event names (i.e. the first letter should be a capital letter), and lowerCamelCase for parameter names. Also please do not use underscores (_).
you might also think about using a shorter extension name... what about ColinTreeScroll instead of ColinTreeVScrollControllerTheOthers ?