My app work on thunkable live, but it doesnt work well when i export it and install it on my phone


#1

Hai all. I have an app that works fine when i tested it using thunkable live. But when i exported it and install it on my phone, the app doesnt work like it works when i use thunkable live. Error with the buttons, looping, etc.

Is there somethin i need to do before export the apk file?

Thanks for ur answer before…


#2

you might want to elaborate
It would really help if you provided a screenshot of your relevant blocks, so we can see what you are trying to do, and where the problem may be.

Taifun


#3

Hai @Taifun, here i attach the screenshot of my blocks. I tried to attach the aia file also but it exceeds the max limit so i will attach the link if u wanna explore more. Thanks before

https://drive.google.com/open?id=1ltSIvlZQx-HkgqAqrkteXo3mFDGmMKwy


#4

unfortunately you did not explain in detail, what kind of issues you are experiencing…
how many Player components are you using?
what about only using one Player component? Just set Player.Source to the corresponding sound you like to play before starting the Player
Taifun


#5

I used a player component for each button. so, i used more than 25 player components. The problem i faced was the app run well when i tried it using thunkable live, but when i export it and install it on my phone it didnt run well. When i pressed next button it just looping on first screen, but in thunkable live, everthing good. Will it change if i use only one player component?


#6

what you are doing is wasting resources… reuse your components!
what about only using one Player component? Just set Player.Source to the corresponding sound you like to play before starting the Player

see tip 1 here


Taifun


#7

Oke, i will edit my component and will reuse my component. But the think is just like my first question and only question. WIll it make a different if i do what u suggest? Because the app run well when i use thunkable live and not when i install it on my phone.


#8

without you trying it I guess we never will find it out
Taifun


#9

image
looks like you are closing ur main screen Fix this It might solve ur issue,

and always put component screen shot like this
image
or design with blocks otherwise It does not give the clear idea about ur problem.