Latest Thunkable Classic / Android Release (Dec 17) - AdMob Troubleshooting Block

admob

#1

Hey Thunkers,

We know many of you have been experiencing ad serving issues with AdMob lately. As it turns out, there are a number of reasons that may be causing the error. To give you better information on the specific cause, we have just released a simple event block that can help you diagnose the specific error that may be causing your troubles.

24%20PM

Error Code Description
0 The Ad Unit ID is wrong or it is a new ID which could take hours to be activated
1 You have entered the App ID or the Publisher ID instead of the Ad Unit ID which begins with ca-app-pub-xxx
2 Please check the mobile device internet connectivity or disable ad blockers on the mobile device
3 Your setup is correct. The issue is that AdMob does not always have an ad to return for every request. This may happen particularly if you have just registered your AdMob publisher ID, as it takes some time and multiple requests before the new ID starts returning ads

Here are other reasons your ad may not be showing up:

We hope this helps many of you self-diagnose your issues quicker so that you can spend your time doing better things!

Albert


AdMob Add Is Not working
Admob is not loading in the application
Ads are showing in live test but not in apk [Merge]
Ads are showing in live test but not in apk [Merge]
What does AdMob error code 3 mean?
Ads are showing in live test but not in apk [Merge]
Ads are showing in live test but not in apk [Merge]
#2

I believe a lot of users are having the 3 error code and the Ad unit id works when using the Thunkable live companion, but there is no Ad when the app is on the Google Play Store. I looked around on the Internet and the problem could be related to the Google Play Store app listing, especially when there is no privacy policy statement. You can see the following StackOverflow post for a possible solution if you have the 3 error code.

Best,
Wei


#3

@albert @wei I think the problem is something else. I have published one of my apps 15-20 days ago. When I downloaded it today from thunkable classic and ran it, non of the ads were loaded but when I downloaded the same app from play store & all of the ads were loaded successfully. There was no change in blocks of both builds & all the ad unit were the same. After I checked for error code & it showed 3. What do you guys think??


#4

Hi there,

Error code 3 means that this has likely nothing to do with your set-up – there’s just not any inventory to show when you opened your app.

I found a bit more details in this article.

"The availability of ads, and what ads are served by AdMob depend on various factors such as location, advertising ID (personalized ads), or non-personalized ads (for EU users - GDPR), app content (linked to Google Play), whether your app is live on Google Play or not, and how many unique devices/users are triggering ad requests. A blank space means no ad was given to your app.

The bottom line is that if you see test ads using your own AdMob IDs, then everything is working properly."

Thanks,
Albert


#5

In which section will find Set-Label-Text-- To get Error Code


#6

@albert
app link - http://bit.ly/2Hoz1cZ . An ad will popup when you open this app for the second time, in case you want to check it.

I know that error code 3 refer to successful setup & no ads to serve but how is it possible that the recent build downloaded from thunkable classics serves no ad & the same app downloaded from play store serves all of them. I tried to load ads multiple times but nothing changes. Even the ad unit are same on both. I ran ad units in both test mode on & off but non of them load an ad. I show you mentioned “whether the app is published on play store or not” as one of the reasons for this but I tried to load ads on one of the old apks I’ve which were not published and it ran ads successfully. I think the issue is something else !!


#7

But is there any new way of setting blocks?
I found this new block that says { when admob interstitial failed to load error code do set admob interstitial to ----------- What will be there?


#8

Please give me a little guide lines on how to create this method that was published on Dec 17th


#9

Im facing same issue. My admob ads are not showing on the apps which i had made recently. No ads are showing on Live test and even after publishing on playstore.

@albert @Taifun - can you tell me what to do… & How to use the below block and what to be inserted in this block to check wheteher ads are working or not

admob


#10

This block shows you the error ! The reason about why you don’t see ads! Some errors can be fix , for other you have only to wait!


#11

@Goldking Can you tell me how to block this in build section. Like what components to ad in this to get the error message.


#12

Add the block and a textbox, the set textbox to error code so you can see the number of the error. With the number read legend


#13

I tried , its showing error 3 in banner ads and for inter its doesnt show any error code. I also tried using vpn then banner ad was visible but no inter ads… can you tell me now what to do?


#14

:point_up_2::point_up_2: This is error number 3 , so you have to wait for


#15

hi all,

can i put the id ads admob on obfucasted component ?? maybe any sugest to hide / encrypt id ads admob ???
thanks


#16

Ok. But why its showing no error for interstial ads?


#17

I don’t know, post some block .


#18


#19

Set screen to responsive (if it isn’t) and only for test try to call ads separately. With a click button or other to force the ads and see if you get the number.


#20

i tried but doesnt work. can i send you my aia file.