I can't open PDF file from internal storage


#36

as workaround I can offer to use the pdf extension https://puravidaapps.com/pdf.php
Taifun


#37

It’s not just about pdf It also applies to other files as well as other properties Action, Package, Class ets, as much as if you add to DataUri file:// or trying to get answers from/with content:// you’re screwed…

Activity component doesn’t work properly…

/Boban


#38

I am looking on it.

Wei


#39

Can anyone send me an apk which I can see the error message?

Thanks,
Wei


#40

Guys now is your chance to provide a sample apk as we have a developer who wants to help.
@Sami_Allaoua @Hitesh

/Boban


#41

its a activity starter error. The other app inventor clones have fixed this error on their platforms recently.


#42

@wei as I don’t have any apk which can show the error for you but you can try from these…

How to view a pdf document
How to pick an image using the activity starter
How to pick a file from SD card with App Inventor

/Boban


#43

aia project file
gg.aia (2.6 KB)

apk file
gg.apk (3.4 MB)


#44

I believe I have a reasonable fix; can you try the following apk file?

gg (27).apk (3.4 MB)

Best,
Wei


#45

its work fine :heart_eyes::heart_eyes:
can you pm the aia file please


#46

@wei Sir PleasE shaRE the image oF BlocKS for the Same APK


#47

This worked however, will this also work :point_down:

/Boban


#48

I will deploy a fix to the instance and it shouldn’t require any work on your end.

Please wait up to 24 hrs.

Thanks,
Wei


#49

The classic platform (app.thunkable.com) is deployed with the fix. Sorry for the delay and please test it :slight_smile:

Just want to let you know we are still committed to Thunkable Classic!!!

Best,
Wei


Thunkable Future Considerations
Will Thunkable Android not available in future?
If Thunkable team plan to no longer support Thunkable classic?
#50

the apk work fine, but stille have the probleme of the platforme ( i use the aia i sended u befor )
please pm use the aia file or some picturs for the bloq.


#51

@wei Sir ThanK YOu so MUCH… NoW ActivitY StartEr is WOrkiNG FinE
:grinning: :sunglasses: :heart_eyes: :open_mouth:


#52

Do you send me the apk/aia you have problem with?


#53

its work fine; thank you all


Activity Starter problem in February 2019 opening pdf-s and docs
#54

Hello Wei!

It seems that Activity Starter doesn’t operating properly now. In my earlier aia-s I used Activity Starter in diverse activities (open pdf, open docs, starting e-mail, starting Google Maps, starting phone, etc…)
Now it doesn’t work to open pdf or docs in test mode and in apk too. It doesn’t work in my earlier aia-s, apk-s (it was worked in January of 2019)
Is it a Thunkable Live problem?
I uploaded a PNG of a test-application, and a screenshot of its live test. The result is the same in all my applications and in all my APK-s, which uses Activity Starter to open pdf-s or docs.
I know that the problem of Activity Starter was fixed in October 2018. I published an APK update (which uses AS to open pdf-s and docs) on Google Play in December 2018, but now I wanted to publish an update of my APK, but I couldn’t because of the error. I think that the Activity Starter is wrong now again.
For live testing and bulding APK-s I use Thunkable Classic Live for Android. (Now I tested test application above in MIT App Inventor 2, and Activity Starter is operating properly in AI2, during testing and built APK too…)
Best regards and thanks: Paul



#55

After updating Thunkable Live Classic Android fixing problem, it’s operating now (15.02.2019), thanks!

Paul


Error when try to open apk file from sd card
Can't open PDF file,since laste update of API