[Free] UDP client extension

extension

#65

It still not works (brodcast = false)
Could someone show me an example?

Ok, but what with my \r?
Is it possible to work?


#66

hi,
thanks for your work.

i have a problem:
i use socket test v 3.0.0
my pc ip is 192.168.1.60 so i start a server udp
on that ip at port 100 e press start listening

after with your extension i put the same ip and same port
but nothing.
i try also broadcast ip 255.255.255.255 but nothing
with broadcast var on true or false.
nothing receive.

why?
thanks


#67

ahi tenes un ejemplo que me esta funcionando. tenes que responderle los mensajes que envia. para que pueda seguir enviando.

en el packet sender podes responder desde settings

fijate de poner tu ip y puerto

suerte


#68

Busca una librería en GitHub que llené las espectatibas que nesecitas y construimos una nueva extencion licencia Mit


#69

Perdon Andres, no conosco bien lo que me decis, pero voy a interiorizarme en el tema, de todas formas, esta extensión a mi me esta funcionando muy bien, muchas gracias otra vez, pero me fijo como se podria mejorar si es a eso a lo que te referis.


#70

Es que hay algo de difusión que no he logrado entender cómo funciona si alguien con más experiencia puede ubicar una librería en Git hub puede convertirla a bloque s


#71

Si puedes compartir un video de tu proyecto


#72

Hi
for the UDPClient.send(), once it trigger.
it is require to wait for the reply. If there is no reply, that particular port will keep occupied and not able to use.

Is it possible to add in timeout attribute for UDPClient.send()
when I set timeout = 0,
I can keep sending multiple UDPClient.send() even there is no reply.


#73

Hola llegó a casa en 4 días, y reviso para añadir el timeout


#75

Hi @Andres_Cotes, you are AWESOME x999 !!!.

The UDPClient.send() works perfectly as capable to perform multi - send() even no reply from server.

However the timeout timer doesn’t seem work as expected.
regardless timeout set 0 or 5000, both are same.
As I thought if timeout set 5000, it should wait for 5sec then only close port/stop waiting for reply .

By the way, @Andres_Cotes , you are still AWESOME as for the fast response on solving the multi-send() issues.

If possible, can you add…“SourceIP” attribute at UDPClient.Receive() and UDPServer.Receive()
then it will be super awesome.
because we can get receive the data at the same time knowing this data is belong to who.

Thanks very much,
Appreciate your effort.


#76

:frowning: why for me not working? What I’m doing wrong?
I’d like to buy the server version but, I can’t run neither the client version!
Why my server not receive nothing?


#77

Send block


#78

from app udp sender my pc receive udp packet.
from phone app built with app inventor and extension not work.
why?


#79

Hi @aigless

The reason why you not able to send the message out, most probably,
you are using the old UDPClient Extension,
which the UDPClient.send() are only able to send once, until it receive a reply from the server.
If the server didn’t reply anything, you will not able to perform the UDPClient.send().

There is two way you can do.

  1. Use the new UDPClient extension with (Timeout) and try again

  2. If you using the old UDPClient extension, once you press the Button1 , your pc can try to send something to your phone(IP) with the same Port (1000),
    and you can press the Button1 to trigger send again.
    but your pc again need to send something back to your phone. Lolol

if without any reply back to your phone, you will not able to perform another UDPClient.send().


#80

thanks for reply, i don’t know witch version i’m using, where can i find the newest?
anyway, i can’t receive nothing in the pc. so how can i reply without no one message sent from app?!

i used another app from my phone to test and it worked. (with UDP SENDER APP)
but with my simple app nothing!
what’s wrong?


#81

Hi @aigless

At very top of this page you will able to see the download link for the
new UDPClient extension with “Timeout”

Try download that new UDPClient extension and re-import to app inventor online.

Thanks


#82

Thanks,
I tryed the time out version. Nothing to do. My pc with socket test 3 can’t receive nothing.
My phone can send packet with udp sender app, when I open app inventor and press button nothing sends. It’s very strange the block are very simple.
When button press call udp function, timeout =100 IP =192.168.1. 60 broadcast false message “test” port 1000.
What’s wrong? It’s all OK? I tryed tcp socket extension and works! Udp client extension not working


#83

hi aigless
try with a port greater than 1024 …
something like 10000
first 1024 ports are reserved for system afaik


#84

@Andres_Cotes
many thanks for this extension …
great works


#85

Hi @Andres_Cotes,

UDPClient extension is Great,
but if you can increase the limit of UDPClient.send() data size from ~700bytes to ~5000bytes or more, then it will be even better.

*As currently each UDPClient .send() only capable to send data that less than 700bytes per time.

Thanks and appreciate all your effort.