[Free] Custom ListView - ColinTreeListView


#343

Hello
Thank you in advance for your work
In my project, I want to make a list of images with titles, from firebase, but when I start the app I get an error message:

The operation select list item can not accept the arguments:, [bacalado.jpg], [(bacalado.jpg callos.png)]

I do not know why this happens
As if I did not have access to the photos, you can help me


#344

hello how can i set a image as extra button i the block editor with the element view block. Because if i use the block, nothing happend, If i put the img in the desgn block, the extra button show the image what i took.

I dont know how to show the image in the extra btton with the block in the block editor. PLs help me


#345

I did use a extension to get the path of the wanted file automatic but this make no changed for me. Nothing work, i cannot set a image for the extra button with the block editor. Bc i wanted to change the img if a user makes a long click on the extra button.
The same thing work for color and text, but not for a image. I dont know what is wrong.

As i told the png image file can be loaded in the designer screen but the blocks editor dont do that and i dont knwo why. Sopls help


#346

Should be doable for customised Listviews :joy:


#347

Yes, but with customised version :blush: please understand that it is not required by everyone so I would not add it in this component


#348

Element index should be a number here, not the element content. (That is a list operating error, not this component’s please discuss this is a new thread!)


#349

Are you setting this via ColinTreeListViewElement component? It would works here.


#350

“shut up an take my money” (cit) then :smiley:


#351

how should someone be able to help you without you providing a screenshot of your relevant blocks?

Taifun


#352

yes i used the seperate component and work in Kodular, maybe there is the problem. I tested it around a half day with no result.

You can put in a picture in the designer screen but not in the block editor and i tried a lot. I tried it with the complete path, with the taifun component for path to asset and so on but make no different you dint see a picture. Pls make a look on this this feature is important, it makes the list a bit more inmteractive if you have a extra button and if you make a long click on it you put the elemt in a list and get a new image if the elelmt is added. YOu make a second long click and you get the old add picture.


#353

you might want to read the documentation about how and when to use this method…
Taifun


#354

i took that component to bc nothing work to change the extra button image, so i thought i have a error in the path.


#355

Let’s open a new thread for your issue, remember to @ me when the thread is created & ready to be helped :smile:


#356

Olá @ColinTree! Pode me dar um exemplo sobre como mudar o Backgroung Color de apenas um item de uma Listview? Obrigado!


#357

Thanks for the update. I just saw it now. Do I need to update it? Because in Thunkable it does not let me set “-1”.
image


#358

SOLVED - I was able to set it on the blocks. Now it is great. Thanks a lot!!!
image


#359


Hi, any solution for that?


#360

How to avoid runtime errors with the companion app

  1. After importing an extension, please restart the companion app.
  2. If you like to use an extension on a different screen, in Screen1 additionally drag the extension into the working area.

While starting the companion app, all necessary assets and also the imported extensions of your project will be copied to your device. So in case the no such class error shows up, the extension code to run the extension is not available on your device. Without that code the companion app is not able to execute methods from the extension.

Taifun


#361

@ColinTree Please add filter bar.


#362

Hi @ColinTree, first, thank you very much for this amazing extension.

I’m making a quotes app and the quotes are displayed in your listview.

I’m passing the selected text to a textbox, for the user customize it, copy, share, etc. But, when i use the Element.Click to get the text from the selection, it comes with a “(” at the beginning and a “)” in the end of the phrase. May i am using the wrong method to get the text? Or we do need to use replace text for remove the ( ):

Below is my blocks image:

And, using the opportunity, is there a way to use the loading dialog with your list? And dismiss it after it’s fully loaded, for example? It’s because my quotes list loads from online JSON and with too many quotes, it’s taking so long to show the list (it stays white while loading and have a little crash before starts to function normally). I tried with the loading dialog with Initialize and dismiss it with Web.GotText, and it show only for a second (the JSON is loaded fast, the problem is transfer it to the list. With the normal Listview it transfer fast… weird).