[Free] Arduino USB Serial Extension

usb
serial
otg
arduino

#144

@pavi2410

Fantastic work on getting this up and running for Arduino. I have been scratching around on github and other places for a solution, and this may be it. I have a resler interface which can be used to talk to the ibus on BMW and Landrover vehicles. It is FDTI with

<usb-device vendor-id="4292" />
<usb-device vendor-id="1027" />

Will this work out of the box ?, can the VID and PID be simply added?, or will a different set of libraries be needed, e.g. https://github.com/mik3y/usb-serial-for-android

Thanks

Tim


#145

Hey @pavi2410 ,

This extension is amazing dude, I’ve been working on a project where an Arduino is serial.print once a RFID tag is read on the arduino.

What I would like to be doing is in MIT app inventor is

IF ‘arduino serial.print tag present’

THEN ‘do stuff in mit app inventor’

What i’ve been doing is using a clock in Mit app inventor so every 3 seconds it set.label1.text= Call Serial.Read

When there is no text on the arduino serial monitor i’ve been reciving an error, is there a way that I can do something like ‘IF call serial.read = EMPTY’ then do nothing ELSE do stuff i want it to do without this error happening?

I hope you can help! The current work around I have is for the arduino to print a serial message every few seconds but I have the problem of when I call serial read I get all the status text I dont care about.


#146

Hi from Spain!
How App Inventor could not have an otg serial connection? Pavi, you are my salvation!
Good news, your extension also works with the Silicon Labs CP2102 serial converter chip…


I am working on a project to connect App Inventor to any OTG Serial device. And after a lot of searching, I found you …
But I have the same problem as Adam, when calling the option “READ” of your extension …

I get a similar error in my application…

Until there are no input characters the value “[nothing]” does not disappear.
I have placed the call to “Read” on a clock with a delay of 100 ms, who waits for “true” in “IsOpen” to get it…
Can you help me? How do I read the entry …?
Or better yet …
You could implement an event like “when a data is received”


#147

I’m glad you’re using this extension. I will try to add a Received event.


#148

It works on WIKO LENNY 3+ Arduino UNO! Thanks!!


#149

I am using your extension through a usb hub. It detects one of the two Silicon Labs that I have connected. Would it be possible to take control of both? I imagine that you could, just as you select the baud rate, choose which tty you want to control.


#150

Hello, everyone, I would like to know if there is any possibility of this extension with microcontroller PIC18F2550.
I thank you for your attention.


#151

i think not !!!
but may be we can use esp(wifi) modual .as per my littil knowledge


#152

bump !

Request for support of CH340G chipsets (used by most el-cheapo clones).

had shared git project which can make this quite easy, if one knows their way around.


#153

Hello pavi2410,
I tried to use your extension, but unfortunately it does not work.
The problem seems to be that I get no message “Allow app … to access the USB device?”.
The connection to the Arduino is ok, tested with a USB terminal program.
Even without Arduino connected, the Softwawe says everything is ok.
My android device is a Samsung A3 (Android 7.0).

What can I do?
best regards.


#154

I’m having exactly same problem (like Johann_Schwarzi in previous post). My device is a Samsung S8 with Android 7.0 and I get no message “Allow app … to access the USB device?”.


#155

Hi @Pierfrancesco_Pan I have the same problem that you have posted in past message: “Runtime error Failed resolution of:Lcom/ftdi/j2xx/D2xxManager” . Please, how have you solved this problem?
I don’t need to communicate with Arduino, I only need to communicate via USB with FTDI breakout, like the app that you have mentioned: https://play.google.com/store/apps/details?id=com.moonappdevelopers.usbterminal
I have tried this app and work very well with my phone (Huawei P9).
Wath I can do?
Thank you and thanks also to Pavitra.


#156

Hello
In the example you show a Block “isOpen”. But I can not find it. Did you provide a function to check if the connection is established/open
Thanks


#157

Ok. Obrigado pela resposta.


#158

Hi, are there any progress regarding the issue where one gets the error cannot accept the arguments: ,[nothing]? Thank you.


#159

It would really help if you provided a screenshot of your relevant blocks, so we can see what you are trying to do, and where the problem may be.

Taifun


#160

Hi Pavi,
I am using ardunio USB Serial extension for get data from FT 232 Driver Board.
I was download latest .aix file for ardunio USB serial Extension. but it doesnot show IsOpen block. and also i got error .
image
Can you help where i am wrong.

How can i Read data Using read Call ardunio read ().if i assign Textview means show error as argument not assigned here.

Can you share Updated ardunio .aix file thanks

Thanks


#161

Please… Repair the “.read” module… Keep giving an error when use it…


#162

if before calling the function read, from an external device a data is sent to the telephone, the error disappears.


#163

may you help me to know if otg cable ( and cellular capability) is required to connect to arduino , or which cable is required for a simple serial dumb connection?