[Free] Arduino USB Serial Extension

usb
serial
otg
arduino

#22

Vendor ID 0403
Product ID 6001
FTDI FT232R


#23

Can I see your blocks along with Do It result on all blocks?
Also .ino file?


#24

/* YourDuinoStarter_SerialMonitor_SEND_RCVE
- WHAT IT DOES:

  • Receives characters from Serial Monitor
  • Displays received character as Decimal, Hexadecimal and Character
  • Controls pin 13 LED from Keyboard
  • SEE the comments after “//” on each line below
  • CONNECTIONS:
    • None: Pin 13 built-in LED
  • V1.00 02/11/13
    Questions: [email protected] */

/-----( Import needed libraries )-----/
/-----( Declare Constants and Pin Numbers )-----/
#define led 13 // built-in LED
/-----( Declare objects )-----/
/-----( Declare Variables )-----/
int ByteReceived;

void setup() /****** SETUP: RUNS ONCE ******/
{
Serial.begin(9600);
Serial.println("— Start Serial Monitor SEND_RCVE —");
Serial.println(" Type in Box above, . “);
Serial.println(”(Decimal)(Hex)(Character)");
Serial.println();
}
//–(end setup )—

void loop() /****** LOOP: RUNS CONSTANTLY ******/
{
if (Serial.available() > 0)
{
ByteReceived = Serial.read();
Serial.print(ByteReceived);
Serial.print(" “);
Serial.print(ByteReceived, HEX);
Serial.print(” ");
Serial.print(char(ByteReceived));

if(ByteReceived == '1') // Single Quote! This is a character.
{
  digitalWrite(led,HIGH);
  Serial.print(" LED ON ");
}

if(ByteReceived == '0')
{
  digitalWrite(led,LOW);
  Serial.print(" LED OFF");
}

Serial.println();    // End the line

// END Serial Available
}
}

//–(end main loop )—

/-----( Declare User-written Functions )-----/

/( THE END )**/


#25

Doesn’t any block works?

Try to use Open block before Write/Read and Close after that


#26

I can see that BytesReceived is an integer variable. So write Data using number block


#27

I have used the NUMBER, nothing, the same Runtime Error: com/physicaloid/lib/usb/driver/uart/UartFtdi

By pc or others app is ok…


#28

No luck here unfortunately :frowning:

I’m using the sample code you provided for the .aia file and in the .ino file I’m communicating at 9600baud and have it setup to blink if any data are received.

Here’s the error on the app:


#29

Hi @burak,

I’m just wondering what USB settings you used to successfully test this?

Do you have USB debugging enabled or disabled? Are your use MTP, PTP, charging(?), or something else in your USB Settings?


#30

Now I’m trying with another phone and I have Runtime error like @Domhnall without USB connection, the error appears clicking on ON or OFF button.
With connection with this other phone when I launch the app I have this error:
Runtime error Failed resolution of:Lcom/ftdi/j2xx/D2xxManager;


#31

I will consider switching to a newer library which should solve the problem


#32

@Domhnall yes active. I use MTP Protocol.


#33

I tried every possibility and unfortunately it does not work. We follow with enthusiasm. I wish you success as soon as possible. Good day … (samsung note 2 android 4.4.2)


#35

All except Read and IsOpen are working.


#36

Didn’t Read block show Toast with result? @burak


#37

Unfortunately I am getting the error message.

https://community.thunkable.com/uploads/default/optimized/2X/a/a573091887dfefd62b86df0887087e9ea6fcd9be_1_500x360.png


#38

Tried with an old app (replaced v2 with v3) and with a new app and got the same error in both cases.

No such class: com.pavitra.Arduino


#40

Arduino.aix (131.3 KB)

Hope this works :grin:


#41

IT WORKS!!!1! :smiley:

I’m no @azaotl when it comes to video editing, but it’s a start! :slight_smile:


#42

It works! Congratulations, Thank you :slight_smile:


#43

jajaja
come on! … video looks really goood! and app looks well done! by the way I’ve never done anything with arduino… maybe someday I will have the chance … looks really interesting :slight_smile: