Error while using TaifunTools along with TaifunSQlite



I am getting above error when I open my project after adding Taifun’s SQLite extension. I already have TaifunTools which is working fine for me.

@Taifun please help.


you might want to import the latest version of the tools extension


Hi Taifun, Thanks for replying.
I downloaded latest file from bottom of page. but i still get same error after upgrading extension.


what happens, if you create a new project and import the 2 extensions there?


I created a new project, imported just SQLite and TaifunTools extension, imported both extensions in screen 1, added a label, added my sqlite database to assets. in blocks I added import database to screen initialize block, and added a Execute clause to return data to Label text. I get same error message.

I am not able to download the project to share here.


I will try some things and let you know…


I can reproduce this issue also with other extensions on the App Inventor server, see my report in the Open Source Group here
we will have to wait for feedback from MIT…



Thank you Taifun for your help.


the problem is now solved, thank you @Ishpreet for finding the issue

the new version 16b of the tools extension is available to download from here



Thanks @Taifun Issue is resolved with new version of extension.