ERROR - "Unfortunately app stopped working"


#1

Hi,
I have a problem with my app. When i install it on my phone and try to open app show error “Unfortunately app stopped working”. I don’t have any idea what is wrong :frowning2: Problem can be somewhere on this part of block on my screenshoots because before i add this blocks to my app it worked good.


#2

Hey,

It looks like you are new to this community.

This question has been asked multiple times before, please use the search button to help find your answer.

Here are a few topics for you to take a look at and try the solutions, if none of the solutions work please let us know.

http://community.thunkable.com/search?q=App%20stopped


#3

I saw that topics but they evry not solved my problem so i started my own topic :wink:


#4

I’ve had problems with this before when I incorrectly entered the firebase values. This form may help you:


You don’t have to worry about the Firebase token though, just leave it at the default value.
Hope this helps! :grinning:


#5

Hmmm… It’s look lik i entered wrong token - i changed it but it still not working :frowning2:


#6

I was looking at the code and saw this:

This may be the cause of the error, because the app is looking for a text value and you have a number there. Try using the .length block with a value instead of the number.


#7

Thanks you a lot! I fixed that but app still not working :frowning2:


#8

Dang it!

Everything looks okay in the code, have you tried it on a different device?


#9

Yes, i tried on older android and it still not work :frowning2:


#10

What is your Firebase URL in your project?
Could you just send a screenshot of the Firebase properties in the designer menu?


#11

Maybe best idea will be to send you all .aia file. I don’t know where i can send it to you - there or e-mail - but i trust that nobody there will hack my app in future so i will send it here :smiley: i will delete it by next week!


#12

what happens, if you disable the FirebaseDB.GotValue event completely? Do you still get that issue?
Taifun


#13

If you want you can share your project aia file with me privat and i will take a look into this :slight_smile:


#14

I will try it tommorow because now i turned my pc :wink:


#15

Ok but as i wrote to Taifun i will make it tommorow because now i turned my pc off :wink:


#16

When i disable all GotValue event it still not work.


#17

All your images has a to big resolution!
And don’t use icons less than more as example 200kb! Your icon was 4MB and the resolution was 1024x1024px

And your other images was to big too.
As example 1024x1700pixel <<<<< too big! :dizzy_face:

Read this:

And this:


#18

Ok! Thanks you a lot! :wink:


#19


MY APP IS NOT START


#20

You should add your adunit to it screen if u placed admob ads in app I had the same problem I had checked that and added the adunit then problem solved