ColinTreeSlideShow (Preview) (NEED HELP)

[Free] ColinTreeSlideshow Version 2 released (2017.9.24)

Extension for slideshow (carousel) is on the way now.

i m writing the document and will release in this weekend~


And i need help for naming

dragRange is the threshold value of the percentage that user dragged, and this drag displacement can make the slideshow scroll to the next slide.
drageRange=Displacement / Width
(min 0, max 1, default 0.2)

the width is 100 px, and user drag the slideshow rightward, for 30px.
At this situation, the percentage 30/100=0.3, is larger than 0.2.
so the slideshow scrolls to the previous slide automatically.

any advice for the naming…?


i got an idea, add the dots ti represent the slides like this:


good boy!
a great extension!
when auto swipe,could you add a event,then noticed which one is current?
thank you.

that is a good idea, i will do it later.

good idea!please go on…

i had changed the method GetSlideNum and GoSlide to property CurrentSlide.
and added two events


Can you make a new .aia testfile?

You mean for the changes that i had made?

Yes please

en que necesitas ayuda

here is the newest sample apk and aia:

Appinventor version: ColinTreeSlideshowTest.apk (1.8 MB)
Thunkable version: ColinTreeSlideshowTest_thunkable.apk (2.6 MB)
Aia: ColinTreeSlideshowTest.aia (302.9 KB)

and it looks like there are still some problem with the new events


i dont know what should i name the method here:

what about sensibilityThreshold or sensibilityValue? Also autoScrollThreshold or autoScrollValue

It’s really awesome.

How to get the slide show extension

it is actually used when user drag it… not when auto-scroll :joy:
maybe sensibilityThreshold is a nice choice?

i will release it these days, don’t be worry

Thanks for making this possible, you are awesome! My idea for the method was something with threshold e.g. scrollThreshold or percentageThreshold

yep that is what i m thinking…
with a "threshold"
but not sure between scrollThreshold & sensibilityThreshold right now