Cloudstitch Spreadsheets Error

I am trying out the Cloudstitch platform with Thunkable and created a simple spreadsheet, following the guidelines of no “:” or “,”. I made sure to press the green “sync with your template” button. In Thunkable, I set the API Endpoint and Table name as the documentation showed. When I used the Get Value Block, I received the runtime error:
Attempt to invoke virtual method ‘int java.lang.Integer.intValue()’ on a null object reference
Note: You will not see another error reported for 5 seconds.
This seems to be an error internal to the Get Value method, I did not have any other blocks running and I triple-checked that I followed the instructions to set up the Cloudstitch Spreadsheet. Any help is greatly appreciated.

same here :frowning:

same here, and after a day of trial and only error what really gets under my skin is the sentence:
Spreadsheets is an easy to use component…

I worked with Firebase, MySql and all the others but this one I can`t grasp.

I made the most simple table (2x2) I read all I could find I double triple (I do not know the word for 100times ) checked the API, the sheet name and all the other stuff. Boy boy, really easy to use component…

JEEZ I found the mistake.
It is in docs.thunkable.com/android/components/storage/spreadsheets.html
there it states that one should replace
https://api.cloudstitch.com/alberthunkable/sf-trees/datasources/sheet
with
https://api.cloudstitch.com/alberthunkable/sf-trees/dev?=true
and that is WRONG!!

You should replace it with
https://api.cloudstitch.com/alberthunkable/sf-trees?dev=true

So not /dev?=true but instead ?dev=true

To prevent further frustration the Doc should be updated

Good luck

3 Likes

@admins might want to correct this in the documentation…
Taifun

1 Like

Thank you for the fix. That edit did work and I haven’t hit further problems with Spreadsheets. I hope this gets changed within the documentation soon.

Note: A similar error will occur if you try to access data from the spreadsheet before using the Get All Data block.

Thanks!

I have used button to load data using spreadsheet ( cloudstitch).
when Button click----> set data to label
but when run the app and click the button same error i found.

---------------Try this-----------------------
press and hold the button it will works fine.

What error?
what Blocks use?

attempt invoke virtual method ´int java.lang. integer.intvalue()´on a null object reference.
End application

SOLVE IT

This is a disrespectful way to ask for help.

1 Like