Camera.take picture crashes live app


#1

I am having trouble with a very simple app. I have only one button and a camera control on the designer screen and the only blocks I have are:

button1.onclick -> camera1.take picture

When I click the button in the Thunkable Live (classic) app, the camera loads and allows me to take a picture. However, when I click “OK” on my phone to use the picture, the app crashes.

I am using a Note 8 with Android 8.0.0

Thanks for any help you can provide!

Kelly


#2

I installed the .apk file on my phone and it does the same thing.


#3

Same app works okay on app inventor.


#4

I just created an app and it crashed as well after clicking OK from a taken photo. I am going to create a new clean photo app to see what is going on.


#5

Something is wonky. Empty app with only one button and the following blocks.

And it crashes after you click OK to confirm the photo was taken. Side note, you can exit out of the camera and back to the app OK. It appears as if when trying to handle the photo it is crashing.


#6

We might break it in the latest release. Can you send me the apk to [email protected]?

Thanks for reporting it!
Wei


#7

Wei,

IT is quicker for you to just create a single button and the blocks I showed above. You can recreate the exact issue.


#8

What android OS version are you using?


#9

I saw the error myself. I will try to get a fix out either tomorrow or by Monday.

Best,
Wei


#10

The fix is released. Can someone please try it out and confirm? The latest companion app version is v3.52.

Thanks,
Wei


#11

I have same problem, and now is fixed, thanks @wei


#12

@wei . It is still crashing for me I am using 3.52 and I did a hard reset on the environment.

It crashes when it tries to upload to Cloudinary now.


Camera Image Path Mangled
#13

Ok so it is now the Cloudinary that is crashing things.

I isolated the Camera function and it still crashed using these blocks


#14

Hi there, I had tried to reproduce this with the current version of Thunkable Classic, but found that my app would not crashes. My phone is running on Android 8, what about yours? This may be a systems adapting issue.
Thanks!


#15

I have tried both 7.0 and 8.0 crash when trying to call Cloudinary in my test.

I have rebuilt the exact block above as an app. Camera is fine, image picker is fine, when you go to Cloudinary it fails.


#16

Hi all,

I tried same above example, and everything is right. my Android is 5.1.1, Samsung Galaxy J3.


#17

It works for me now. Thanks!


#18

While camera works, the Cloudinary process does not.

I have tried, with a new account, with Firefox as the browser. Here are the blocks.

They fail on both 7.0 and 8.0

Once the cloudinary is called, it crashes.


#19

Ok I have debugged this further. If I delete the .GotResponse . I do not get a fatal crash. I get an onscreen Notice error on the mobile device. This is all testing in Live.

It says.

"Error 1104 unable to post or put file “” with the specified URL cloudinary"

I did a bit more debug and this is the error with more detail.

Unable to post or put the file “” with the specified URL cloudinary.PostFi[email protected]9e0517fUnable to post or put the file “” with the specified URL cloudinary.

@wei
@Moayad_Zaidan
@ColinTree


Newer Version of Thunkable error
#21

Okay I will have a test on this issue,